source: app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-99999999-r1.ebuild @ cd98434

Revision cd98434, 1.4 KB checked in by geos_one <geos_one@…>, 10 years ago (diff)

redigest

git-svn-id: https://svn.disconnected-by-peer.at/svn/linamh/trunk/linamh@2897 6952d904-891a-0410-993b-d76249ca496b

  • Property mode set to 100644
Line 
1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5EAPI="2"
6
7DESCRIPTION="Metapackage to provide 32bit libraries via multilib"
8HOMEPAGE="http://www.gentoo.org/"
9LICENSE="GPL-2"
10
11KEYWORDS="-* ~amd64"
12SLOT="0"
13IUSE="+dbus kde -nodep opengl +qt3 +qt4 +svg +sql +webkit"
14
15DEPEND="!nodep? ( opengl? ( app-admin/eselect-opengl ) )"
16
17RDEPEND="!nodep? ( =app-emulation/emul-linux-x86-baselibs-${PV}
18                =app-emulation/emul-linux-x86-soundlibs-${PV}
19                =app-emulation/emul-linux-x86-xlibs-${PV}
20                qt3? ( !qt4? ( x11-libs/qt:3[multilib_abi_x86] ) )
21                qt4? ( x11-libs/qt-core:4[multilib_abi_x86]
22                        x11-libs/qt-gui:4[multilib_abi_x86]
23                        svg? ( x11-libs/qt-svg:4[multilib_abi_x86] )
24                        sql? ( x11-libs/qt-sql:4[multilib_abi_x86] )
25                        x11-libs/qt-script:4[multilib_abi_x86]
26                        x11-libs/qt-xmlpatterns:4[multilib_abi_x86]
27                        dbus? ( x11-libs/qt-dbus:4[multilib_abi_x86] )
28                        opengl? ( x11-libs/qt-opengl:4[multilib_abi_x86] )
29                        !kde? ( || ( x11-libs/qt-phonon:4[multilib_abi_x86] media-libs/phonon[multilib_abi_x86] ) )
30                        kde? ( media-libs/phonon[multilib_abi_x86] )
31                        qt3? ( x11-libs/qt-qt3support:4[multilib_abi_x86] )
32                        webkit? ( x11-libs/qt-webkit:4[multilib_abi_x86] )
33                        x11-libs/qt-test:4[multilib_abi_x86]
34                        x11-libs/qt-assistant:4[multilib_abi_x86] ) )"
35
36pkg_postinst() {
37        #update GL symlinks
38        use opengl && eselect opengl set --use-old
39}
Note: See TracBrowser for help on using the repository browser.